Distributed LAN Monitor

DLM_Agent

Supports Management Module SM-CSI1028

Device Management
Contents

INTRODUCTION .................................................................4
   DLM Definitions...............................................................4
   Devices That Support DLM.............................................5
   DLM and SPECTRUM ...........................................................5

THE DLM AGENT MODEL ....................................................6
   Application View Relations..............................................7
   The DLM Agent Icon .......................................................7
   Model Information View Label .....................................8
   Attribute Walk/Contact Status Label .........................9
   SNMP Poll Table Label ...............................................9
   DLM Agent Icon Subviews Menu Selections .................9

USING DLM .........................................................................11
   Effective DLM Configurations .....................................11
   Using DLM in SPECTRUM ...........................................13
   The Monitors View ........................................................15
   Adding New Polled Entries .........................................15
   Monitors View Description .........................................16
   The SNMP Poll Table ..................................................18
   The SNMP OID Table ..................................................19

INDEX .............................................................................21
Introduction

This section introduces the Distributed LAN Monitor functions and related definitions.

This section provides an introduction to the DLM MIB and its implementation in SPECTRUM. The Distributed LAN Monitor (DLM) Client function of SPECTRUM allows you to reduce network SNMP traffic by delegating the polling responsibilities of your management workstation to one or more strategically placed “smart” devices on your network. These DLM Servers can be configured to locally poll any SNMP or ICMP device on your network and notify the management station of any communication problems. DLM gives these devices the ability to serve as micro-monitors for their segments of a network. This greatly reduces the number of devices reporting directly to the management station, freeing up bandwidth, and improving overall network performance. DLM devices are best placed on a segment of the network bounded by filtering devices (bridges or routers).

DLM Definitions

A **DLM Server** is a device that contains an SNMP agent that implements the Cabletron DLM MIB. An SNMP management station can delegate its polling responsibilities by creating entries in the snmpPollTable in a DLM Server device. For our purposes, a DLM Server is a device that has been configured to poll other devices on its segment of the network.

A **DLM Polled Device** is a device being polled by a DLM Server. DLM Polled devices are not in direct contact with SpectroSERVER as long as the table entry establishing the poll is active and the DLM Server is operational.

A **DLM Client** is the network management station that is communicating with the DLM Server devices and receiving information about the DLM Polled devices. In this case, your SPECTRUM workstation is the DLM Client.
Devices That Support DLM

The DLM feature is supported by any Cabletron device using Intel’s i960 microprocessor.

Table 1 shows devices that can be modeled in SPECTRUM that support the DLM feature.

Table 1: DLM Supporting Devices

<table>
<thead>
<tr>
<th>Device Name</th>
<th>Model Type Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>EMM-E6</td>
<td>BRtrCSIEMM_E6</td>
</tr>
<tr>
<td>NBR-620</td>
<td>BRtrCSINBR620</td>
</tr>
<tr>
<td>ETWMIM</td>
<td>BdgCSIETW</td>
</tr>
<tr>
<td>EMME</td>
<td>HubCSIEMME</td>
</tr>
<tr>
<td>MicroMMAC</td>
<td>BRtrCSiMMAC</td>
</tr>
<tr>
<td>MRXI-22/24</td>
<td>HubCSIiMRXi</td>
</tr>
</tbody>
</table>

Note:

MRXI-22/24 devices running firmware versions earlier than 2.00.00 do not support the DLM feature. For information about upgrading your device’s firmware, contact Aprisma Management Technology’s Technical Support.

DLM and SPECTRUM

A model is created automatically for the DLM application and this model appears in the Application view of the DLM supporting device. The DLM application model is associated to the DLM supporting physical device model with the “Manages” relation.

Note:

If you are running a previous version of SPECTRUM, the following user interface aspects may differ from those in SPECTRUM version 4.0:
- Order and names of menu selections
- Navigational features (mouse button functionality)
The DLM Agent model appears as an icon in the DLM supporting device’s Application view. All SPECTRUM subviews available for the DLM Agent model are accessed from this icon. Figure 1 provides an example of the DLM Agent model as it appears in an Application view in Icon Mode.
Application View Relations

The Application view displays the SPECTRUM relations between the respective device model and the applications it supports. The device model at the top of the view uses the “Manages” relation to monitor the DLM application.

The DLM Agent Icon

The DLM Agent Icon is divided into three zones, providing button functions and visual status presentations. Figure 2 provides a detailed illustration of the DLM Agent icon. Information for each icon area follows. The menu displayed is accessed by clicking the right mouse button on the icon.
Figure 2: DLM Application View Icon Detail

- **Model Information View Label**: The Model Information View Label displays the default model name (DLM App) and provides a double-click zone that opens the DLM Agent Model Information view.

- **Attribute Walk/Contact Status Label**

- **SNMP Poll Table Label**
Attribute Walk/Contact Status Label

The Attribute Walk/Contact Status Label changes color to reflect the current DLM Agent contact status and provides a double-click zone that opens the DLM Agent Attribute Walk. Contact status color definitions for a DLM Agent model are either Contact Established (Green) or Contact Lost (Red).

SNMP Poll Table Label

The SNMP Poll Table Label on the DLM Agent Icon displays the model type name (DLM_Agent) and provides a double-click zone that opens the SNMP Poll Table view.

DLM Agent Icon Subviews Menu Selections

The previously mentioned views as well as additional views are available from the DLM Agent Icon through the Icon Subviews menu. Clicking on the icon to highlight it and then selecting Icon Subviews from the View menu, or clicking the right mouse button, accesses the Icon Subviews menu. Table 2 provides a brief description of the Icon Subviews menu selections available from the DLM Agent Icon.

Table 2: DLM Agent Icon Subviews menu Selections

<table>
<thead>
<tr>
<th>Menu Selection</th>
<th>Opens the...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Navigate</td>
<td>Navigator sub-menu, allowing you to Navigate In or Up. For more information on the Navigator sub-menu refer to the SPECTRUM Menus documentation.</td>
</tr>
<tr>
<td>Utilities</td>
<td>Utilities sub-menu, allowing you to access utilities you have purchased for SPECTRUM, such as PathView.</td>
</tr>
<tr>
<td>Notes</td>
<td>Notes facility for the DLM Agent model.</td>
</tr>
<tr>
<td>Events</td>
<td>SPECTRUM Events Log containing events (if any) for the DLM Agent model.</td>
</tr>
<tr>
<td>Alarms</td>
<td>SPECTRUM Alarms View containing alarms (if any) for the DLM Agent model.</td>
</tr>
<tr>
<td>Monitors</td>
<td>DLM Agent Configuration View.</td>
</tr>
</tbody>
</table>
### Table 2: DLM Agent Icon Subviews menu Selections (Continued)

<table>
<thead>
<tr>
<th>Menu Selection</th>
<th>Opens the...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Attribute Walk</td>
<td>Attribute Walk view that displays the attributes supported by the DLM Agent model type. The user may select attributes to view or may group attributes to create new Generic views for the DLM Agent model.</td>
</tr>
<tr>
<td>Acknowledge</td>
<td>Acknowledges that an alarm has occurred for the DLM model, stops the Information view label from blinking, but does not clear the alarm.</td>
</tr>
<tr>
<td>Poll Table</td>
<td>SNMP Poll Table.</td>
</tr>
<tr>
<td>OID Table</td>
<td>SNMP OID Table.</td>
</tr>
<tr>
<td>Model Information</td>
<td>DLM Agent Model Information view.</td>
</tr>
</tbody>
</table>
This section explains how to use DLM on your network.

Effective DLM Configurations

DLM can limit the amount of polling traffic on a network if the polled devices for a given DLM Server are selected carefully. Each DLM Server device should be configured to poll only those devices that reside in its segment of the network, i.e., a subset of the network bounded by filtering devices (bridges or routers). When DLM is properly configured, the only polling traffic that would extend beyond the filtering devices would be that between the SPECTRUM workstation and the DLM Server device. Figure 3 illustrates one such DLM configuration.
Figure 3: Using DLM Effectively

- **DLM Client** (SPECTRUM Workstation)
- **Filtering Devices**
- **DLM Server Device**
- **DLM Monitored Devices or Discrete LANs**
- **EMME**
- **MRXI-24**
Using DLM in SPECTRUM

Using DLM in SPECTRUM requires configuring DLM to actively poll selected devices or discrete LANs. This involves two procedures.

1. Copying the device or discrete LAN model from any SPECTRUM view.

2. Pasting the device or discrete LAN model into the DLM Monitors view.

The model is automatically added to the SNMP Poll Table and the SNMP OID Table if an Object Identifier is supported. Figure 4 provides an overview of this process.

**Note:** When a discrete LAN model is pasted into the Monitors view, all device models that the LAN model is collecting are automatically assigned to DLM. When a discrete LAN model is erased from the Monitors view, DLM no longer polls the device models.
Figure 4: Using DLM in SPECTRUM

Copy device or discrete LAN to be monitored by DLM from a SPECTRUM view.

Paste device or discrete LAN into the DLM Agent Monitors view.

Model is automatically added to the DLM's SNMP Poll Table.

If the model supports an Object Identifier (OID), it is also added to the DLM's SNMP OID Table.
The Monitors View

Access: From the DLM_Agent icon, select Monitors from the Icon Subviews menu.

The Monitors view contains icons representing model types monitored by DLM.

Adding New Polled Entries

To add a new DLM polled entry to the Monitors view follow these steps:

1. Navigate to the SPECTRUM view containing the model you want to have DLM poll.
2. Highlight the device or discrete LAN model.
3. Select Copy from the Edit menu.
4. Navigate to the Monitors view.
5. Select Paste from the Edit menu.

Before DLM will start polling a newly added model, the following conditions must be met:

- For an SNMP model, the model state should be Active and the model’s contact status should be Established.
- For an ICMP model, the model’s contact status should be Established.

Note: When you add a discrete LAN model to the Monitors view, all the devices modeled in the LAN model appear as separate polled entries. The Monitors view has a limit of 64 models for the EMME and 24 models for the MRXI-24 that can be polled by the DLM Agent. If you copy and paste a discreet LAN model that contains more models than these limits into the Monitors view, it will appear that all entries are being polled when some are not. Access the Event Log to determine which models are or are not being polled.
Monitors View Description

An entry representing each managed device appears in the DLMMONITORS list. Double-clicking on an entry selects the respective device model which appears in the top half of the Monitors view. Generic views for the particular device model can be accessed by highlighting the icon and selecting the Generic view of interest from the Icon Subviews menu.

Each entry in the DLMMONITORS list provides the following additional information about the individual device model:

**Model Type Name**
The device model’s model type name.

**Model Name**
The user-defined model name.

Entries in the DLMMONITORS list can be filtered according to Model Name or Model Name Handle and Model Type or Model Type Handle. To filter entries, select **Filter...** from the Tools menu and enter the type of filtering required. This feature allows a user to view only a particular model or model type if the number of models managed by one DLM Agent is extensive.

Entries in the DLMMONITORS list can be searched for according to Model Name or Model Type Name. To search for entries, select **Search...** from the Tools menu and enter the type of search required. This feature allows a user to view only a particular model or model type if the number of models managed by one DLM Agent is extensive.

Selecting **Statistics** from the Tools menu provides information on the number of entries in the DLMMONITORS List and the number of entries that have been filtered.

**Figure 5** shows an example of the Monitors view.
Figure 5: The Monitors View

Icon for the device model highlighted in the list below. Use the icon to access Generic views for this model.

List of device models. Use the scroll bar to scroll through the list. The color of the entry indicates the model’s status.
The SNMP Poll Table

**Access:** From the DLM_Agent icon, double-click on the SNMP Poll label.

The SNMP Poll Table contains a list of device models being polled by DLM. The SNMP Poll Table is read-only, no entries can be changed by the user.

The SNMP Poll Table provides the following information:

- **Destination**
  The IP Address of the host or device to be polled.

- **Owner**
  The IP Address of the client that created this poll request entry.

- **Poll Protocol**
  The protocol used to poll the device. Possible protocols are SNMP or ICMP-ping.

- **Action**
  The action to take when a poll request has failed. A value of no-action allows the poll to reset and retry without sending any alarms. A value of send-trap causes an SNMP Trap-PDU to be generated and sent to the specified trap address for this entry.

- **Type**
  The administrative control of this poll request entry. A value of activate begins polling of this entry. A value of suspend stops polling of this entry but leaves the entry in the table. A value of invalid stops polling of this entry and removes the entry from the table.

- **Status**
  The operational status of this poll request entry.

- **Last Contact**
  The SystemUpTime value when the last poll response was received from the polled host or device for which this poll entry exists.

- **Last Alarm**
  The SystemUpTime value when the last alarm was generated for this poll request entry.

- **Alarm Wait**
  The number of seconds to wait before sending another alarm. This prevents a flood of alarms from being generated if a device’s contact is lost.

- **Poll Interval**
  The value in seconds of the poll interval with which to poll a destination address that has OIDs defined in the OID table. This interval defines how often an SNMP Get-Request PDU will be originated from the host device to the polled
address. This value is copied from the corresponding SPECTRUM model’s Poll Interval.

**Poll Retries**
The number of times to retry a failed poll request before it is considered a failure. This value is copied from the corresponding SPECTRUM model’s DCM Retry interval.

**Requests**
The number of poll requests (SNMP Get-Request PDUs) that have been issued for this poll entry.

---

**The SNMP OID Table**

*Access:* From the DLM Agent icon, select **OID Table** from the **Icon Subviews** menu.

The SNMP OID Table contains a list of device models being polled by DLM that support Object Identifiers. The SNMP OID Table is read-only, no entries can be changed by the user.

The SNMP OID Table provides the following information:

**Destination**
The IP Address of the host or device to be polled by DLM.

**Owner**
The IP Address of the client (EMME or MRXI-24) that created this OID request entry.

**Object ID**
The object identifier to be polled. This OID value is placed in an SNMP Get-Request PDU on each poll interval. The default is `sysUptime`.

**Comparator**
Indicates the type of comparison to be performed on the value portion of the OID being polled. This comparator will be used to compare the OID value with the threshold value defined in this entry. The default is `don’t-compare`.

**OID Enum**
Indicates the type of value (integer, counter, gauge, or ticks) to expect from the OID being polled.

**OID Type**
The administrative control of this OID entry. Possible types are: `other`, `inactive`, `active`, and `suspend`.

**OID Status**
The status of this OID as of the last poll. Possible status values are: `inactive`, `active`, or `alarm-condition`.

---

---
Last Value
The value of the last poll as an integer value.
Index

A
Action 18
Alarm Wait 18
Application View 7, 8
  Icon Detail 8
  Relations 7
Application View Mode
  Changing 11
Attribute Walk 9

C
Comparator 19
Contact Status
  Label 9

D
Destination 18, 19
DLM 9, 11
  Agent Icon 7
  Agent Icon Subviews Menu
    Selections 9
  Agent Model 6
  Effective Configurations 11

L
Last Alarm 18
Last Contact 18
Last Value 20

M
Model 16
  Name 16
  Type Name 16
Model Information View 8
  Label 8
Monitors View 15, 16
  Description 16

N
Navigator 9

O
Object ID 19
OID 19
  Enum 19
  Status 19
  Type 19
  Owner 18, 19

P
Poll 18, 19
  Interval 18
  Protocol 18
  Retries 19
Polled Entries
  Adding 15

R
Requests 19

S
SNMP 9, 18