Annotation Toolbox
Notice

Aprisma Management Technologies, Inc. (Aprisma) reserves the right to make changes in specifications and other information contained in this document without prior notice. The reader should in all cases consult Aprisma to determine whether any such changes have been made.

The hardware, firmware, or software described in this manual is subject to change without notice.

IN NO EVENT SHALL APRISMA, ITS EMPLOYEES, OFFICERS, DIRECTORS, AGENTS, OR AFFILIATES BE LIABLE FOR ANY INCIDENTAL, INDIRECT, SPECIAL, OR CONSEQUENTIAL DAMAGES WHATSOEVER (INCLUDING BUT NOT LIMITED TO LOST PROFITS) ARISING OUT OF OR RELATED TO THIS MANUAL OR THE INFORMATION CONTAINED IN IT, EVEN IF APRISMA HAS BEEN ADVISED OF, KNOWN, OR SHOULD HAVE KNOWN, THE POSSIBILITY OF SUCH DAMAGES.

Copyright © June 2000 by Aprisma Management Technologies, Inc. All rights reserved.
Printed in the United States of America.
Order Number: 9032520 -01

Aprisma Management Technologies, Inc.
121 Technology Way
Durham NH 03824

SPECTRUM, the SPECTRUM IMT/VNM logo, DCM, IMT, and VNM are registered trademarks, and SpectroGRAPH, SpectroSERVER, Inductive Modeling Technology, Device Communications Manager, and Virtual Network Machine are trademarks of Aprisma or its affiliates.

C++ is a trademark of American Telephone and Telegraph, Inc.
UNIX is a trademark of UNIX System Laboratories, Inc.
OSF/Motif and Motif are trademarks of the Open Software Foundation, Inc.
X Window System is a trademark of X Consortium, Inc.
Ethernet is a trademark of Xerox Corporation.

Virus Disclaimer

Aprisma makes no representations or warranties to the effect that the Licensed Software is virus-free.

Aprisma has tested its software with current virus checking technologies. However, because no anti-virus system is 100% reliable, we strongly caution you to write protect and then verify that the Licensed Software, prior to installing it, is virus-free with an anti-virus system in which you have confidence.
Restricted Rights Notice

(Applicable to licenses to the United States Government only.)

1. Use, duplication, or disclosure by the Government is subject to restrictions as set forth in subparagraph (c) (1) (ii) of the Rights in Technical Data and Computer Software clause at DFARS 252.227-7013.


2. (a) This computer software is submitted with restricted rights. It may not be used, reproduced, or disclosed by the Government except as provided in paragraph (b) of this Notice or as otherwise expressly stated in the contract.

(b) This computer software may be:

(1) Used or copied for use in or with the computer or computers for which it was acquired, including use at any Government installation to which such computer or computers may be transferred;

(2) Used or copied for use in a backup computer if any computer for which it was acquired is inoperative;

(3) Reproduced for archival or backup purposes;

(4) Modified, adapted, or combined with other computer software, provided that the modified, combined, or adapted portions of the derivative software incorporating restricted computer software are made subject to the same restricted rights;

(5) Disclosed to and reproduced for use by support service contractors in accordance with subparagraphs (b) (1) through (4) of this clause, provided the Government makes such disclosure or reproduction subject to these restricted rights; and

(6) Used or copied for use in or transferred to a replacement computer.

(c) Notwithstanding the foregoing, if this computer software is published copyrighted computer software, it is licensed to the Government, without disclosure prohibitions, with the minimum rights set forth in paragraph (b) of this clause.

(d) Any other rights or limitations regarding the use, duplication, or disclosure of this computer software are to be expressly stated in, or incorporated in, the contract.

(e) This Notice shall be marked on any reproduction of this computer software, in whole or in part.
Contents

Annotation Toolbox Features 5
  Accessing the Annotation Toolbox ................................................................. 5
  Annotation Toolbox Tools ............................................................................. 6
  Annotation Toolbox Settings ........................................................................ 7
    Keep Tool .................................................................................................. 7
    Show Text Background Color .................................................................. 7
    Foreground ............................................................................................... 8
    Background ............................................................................................. 8
    Line Styles .............................................................................................. 9
    Line Width ............................................................................................... 10
    Fill Styles ................................................................................................ 11
    Font ......................................................................................................... 12

Adding and Editing Annotations 15
  Changing Default Settings .......................................................................... 19

Index 21
Annotation Toolbox Features

This section describes the Annotation Toolbox and the toolbox settings in SPECTRUM views.

Accessing the Annotation Toolbox

To access the Annotation Toolbox, from the main window in SPECTRUM (Universe level), choose File > Edit. Once you are in the edit mode, choose Edit > Annotation Toolbox &.

A user must have write permissions to access the Annotation Toolbox. See the Security section of the UserEditor for information about setting permissions.

The Annotation Toolbox, shown in Figure 1, allows you to edit SPECTRUM views by adding lines, circles, boxes, and text. The toolbox provides several graphic tools to enhance a view’s background by adding extra graphics or text.
Annotation Toolbox Tools

The Annotation Toolbox provides several graphic tools that allow you to make an annotation. You select these tools by clicking on the Tools buttons next to the tool you wish to use. The tool is selected when the button is recessed. The following tools are available:
Annotation Toolbox Settings

The Annotation Toolbox provides several settings for the selected tools. Select these settings by clicking on the box next to the setting. The setting is selected when the box is recessed. When the setting is enclosed within a box, you can toggle the setting using the Enter key. The following settings are available:

**Keep Tool**

Keeps the tool selected after making an annotation.

- **Recessed**
  - Annotation tool remains open after each use.

- **Raised**
  - Annotation tool closes after each use.

**Show Text Background Color**

Enables (button is recessed) or Disables (button is raised) showing the text background color.
Foreground

Selects the outline color for graphic annotations (lines, boxes, and circles), the color of text characters and the fill color used in box and circle annotations. Foreground color provides the primary color for recessed boxes and raised boxes.

To change the foreground color, select the Foreground button and choose a color from the Select Color Index dialog box. The box to the right of the Foreground button displays the current color selection.

Note: The Select Color Index dialog box displays the available colors with number. These numbers internally represent what the actual color is.

Background

Background color provides the color for text annotations (other than recessed/raised boxes).

To change the background color, select the Background button and choose a color from the Select Color Index dialog box. The box to the right of the Background button displays the current color selection. ShowText Background Color must be Recessed for use with text.

For information about standards that are supported using tiff images for a background raster, see the document, TIFF Revision 6.0 at this address: http://www.adobe.com/Support/TechNotes.html
Line Styles
Sets the style for line annotations. Use Line Styles for line, circle, and box annotations.

Solid

Solid line can border an annotation without Fill.
Annotation Toolbox Features

**Dashed**

Alternating Foreground Color and transparency with Fill Off

![Dashed Line Example](image)

**DoubleDashed**

Alternating Foreground Color and Fill Off

![Double Dashed Line Example](image)

**Line Width**

Changes the thickness of lines created by the line, box, and circle tools. Each object is drawn using the currently selected line thickness.
Fill Styles
Sets the style of fill for the graphic.

Unfilled
Font

Select a font name from the Font column and choose the weight, slant, or point size for the selected font. The available column choices change depending on the selections you make. For example, if you require a 10-point font with an italic slant, you may find that these selections are available only for the helvetica and courier fonts in medium and bold weight.
The full font name is displayed in the Font Name box. An alphabetic and numeric sample of the selected font is also displayed. If a selection is not made from any of the columns, the defaults are: courier, medium, roman, 14. If these defaults are not available, the first entry in each column is used as the default.

You can also view the available fonts by clicking the Font List button which opens the Font List dialog box (Figure 2). The scroll bar allows you to view all available font combinations. Using the Filter greatly reduces the time it takes to locate a specific font/weight/size combination. Enter a substring of an entry to perform a substring search. Only those entries that match the substring will be displayed. For example, to list only courier entries, type courier in the Filter field. To list only courier medium entries, append -medium to the field (for example, courier-medium. Do not add any spaces between courier and medium).
Double-click on an entry or highlight the font you want from the Font List and then click OK. You will return to the Annotation Toolbox window where the Font Name box will display the font you selected from the Font List.
Adding and Editing Annotations

This section provides step-by-step procedures on editing display colors, line attributes, text fonts, and making annotations within SPECTRUM Views.

To add annotations to a view, place the view in Edit mode and select Annotation Toolbox from the Edit menu. Depending on the annotation you are adding, there may be several steps involved to add annotations. Once an annotation has been added, click on it with the mouse pointer to drag it to another location. Text is moved by highlighting and dragging to a new location. Remember that when a tool or setting is enabled, the button is recessed. When it is disabled, the button is raised.

To reshape the annotation, you can click on the edge or corner handles and drag the annotation to the desired shape and size. To close the Toolbox, select Close, then Save & Close from the File menu to exit the Edit mode. Or place the pointer anywhere in the Toolbox and press the right mouse button to exit.

Select Foreground button and choose a color from the Select Color Index dialog box. Perform the following Tasks as needed.
**Task** – To add (and Edit) text annotations

1. Select *Show Text Background* button to use a background color.

For a transparent background, disable *Show Text Background* for no text background color.

2. Select *Background* button and choose a color.

3. Select a font from *Font List*.

The font can be changed by choosing a new font style, which will change all of the text you are entering.

4. Select *A* button in the *Tools* portion of the Toolbox and move the mouse onto the view.

Click the mouse to place the text cursor onto the view.

5. Type a line of text and press return to end.
Edit the line by backspacing or delete text that is incorrectly entered using the arrow key to highlight the text and then select Cut from the Edit menu. Using Cut allows you to Paste the text somewhere else. To permanently delete the text, use Erase.

**Task – To add line annotations**

1. Select the *Line Style* button and choose *Solid, Dashed, or DoubleDashed*.

2. Slide *Line Width* to adjust line width.

3. Select a *Foreground* color for all line styles and a *Background* color for *DoubleDashed* lines only.

4. Select \ button in *Tool* portion of Toolbox and place the pointer at the desired starting point.

5. Press and hold the left mouse button and drag to draw a line. Release the button to end the line.
Adding and Editing Annotations

Annotation Toolbox Tools

The Annotation Toolbox Tools are used on a grid (Edit mode) so when you are adding lines, squares, circles, or text they will snap to the grid. Your text or drawing will move within the confines of the grid squares.

Note:

Task – To add circle or box annotations

1. Select Solid, Dashed, or DoubleDashed from Line Style.

   Fill should be set to Raised when using Dashed and DoubleDashed Line Styles.

2. Select Fill Style.

   The fill choices are Filled, Raised, or Recessed for shapes that have a fill color.

3. Select Foreground button and choose a color from the Select Color Index dialog box for a fill.

4. Adjust the Line Width.
Adding and Editing Annotations

Annotation Toolbox Tools

5. Select a tool from the Tools portion of the Toolbox for the shape you want.

6. Place the tool in the view to begin drawing, pressing and holding the left mouse button and dragging until it is the size you want.

7. Release the mouse button when you have the desired size shape.

Changing Default Settings

You can change the Annotation Toolbox default settings by modifying its associated resources. Resource names and settings are as follows:

- `*annTool*`: Line, Box, Circle, Text, Pointer (default)
- `*annKeepTool*`: True, False (default)
- `*annLineStyle*`: Dashed, Doubledashed, Solid (default)
- `*annLineThickness*`: 1-10 (default=1)
- `*annFillStyle*`: On, Raised, Recessed, Off (default)
- `*annShowTextBackground*`: True, False (default)
- `*annForegroundColor*`: 77 - 255 (default=252, white)
- `*annBackgroundColor*`: 77 - 255 (default=244, black)
- `*annFontName*`: any valid font (default=9x15)
- `*annBoldLabelFont*`: any valid font (default=9x15B)
- `*annotationOnTop*`: True, False (default)

For more information about changing these resources, refer to the Defining Resources documentation.
Index

A
Annotation Toolbox
   Accessing 5
   general information 5
   making an annotation 5
Annotation Toolbox settings 7
Annotation Toolbox Tools 6
annotationOnTop 19

B
Background 8

C
Changing Default Settings 19
Closing the Toolbox 15
Cut annotations 17

D
Defining Resources 19

E
Edit annotations 17
Erase annotations 17

F
Fill Styles 11
   Filled 12
   Raised 12
   Recessed 12
Font 12
Font List 13
   Filter 13
   Font Name 13
Foreground 8
   Select Color Index 8

K
Keep Tool 7

L
Line Styles
   Dashed 10
   DoubleDashed 10
   Solid 9
Line Width 10

P
Paste annotations 17
R

Resources
  annBackgroundColor 19
  annFillStyle 19
  annFontName 19
  annForegroundColor 19
  annShowTextBackground 19
  annTool 19
  Restricted Rights Notice 3

S

Select Color Index
  Background 8
  Foreground 8
  ShowText Background Color 8

T

trademarks 2

U

UserEditor
  Setting Permissions 5